Jump to content



to add your 300x250 banner, pay ad zone 5
Airsoft Atlanta is your source for quality airsoft guns and rifle parts
to add your Text Link here, pay ad zone 3

AirsoftAtlanta.com AirsoftNMore.com Airsplat.com AirsoftRC.com
Vote for us to add your 180x30 banner here, pay ad zone 2

If you appreciate this website, please ASF Donation or Check Out the ASF Store. If you can not help us financially,
then at least help us by telling a friend: Share us on your favorite social networking website Bookmark and Share

Important Announcement!

Our Pinzgauer Project is in "Pre Launch" - Click Here to let us know what you think before the project goes live.

Photo
- - - - -

Kwa Double Stack Magazine Feed Problem(usp Full Size)


  • Please log in to reply
5 replies to this topic

#1 c4v3man

c4v3man

Posted 13 April 2008 - 10:34 PM

I purchased a KWA KP8 USP full size pistol back in december, shot about 1000 rounds through it without many problems (maybe like 5 jams/misfeeds). Then I started having CONSTANT problems. I took it back, and after them working on it for a few months, I returned it and purchased one from another supplier. I started having double feeds and jams right off the bat. I am using propane and green gas alternating, and Excel and Airsoft Elite .20 pellets (new, not re-using). Prior to me sending my pistol back to the supplier, I wanted to know if there is anything I can try. I saw a post here that describes part of my problem, and I tried adjusting the hop up on my first pistol before without success. I will try it again tonight, however I doubt I will have much more luck.

Normally I would simply try a different model or brand, however I need my pistol to be a HK USP pistol, since my IWB holster is made for my USP expert, which I concealed carry. I purchased this airsoft simply to allow for me to practice shooting and drawing (potentially for IPSC) cheaper than reloaded .45's. If there is another brand of USP that is known to be more reliable, I would be willing to try that, however it seems unlikely that a manufacturer as good as KWA (from what I hear) would make a known defective product. I clean my pistol regularly, and am using some Gold Cup lubricant on the rails and barrel assembly. I'm going to try putting a spot of oil on the hopup, and perhaps some at the top of the feed lips. Is there anything else I can do?

Problems:
1. Double feed (something it will fire nothing the shot before, sometimes it will shoot 1 then shoot 2)
2. BB will feed in between the hopup/barrel and magazine, causing jam
3. BB will "eject" out of the ejection port while another bb loads fine


Thank you for your help.

#2 Seven

Seven

Posted 13 April 2008 - 10:55 PM

make sure you only pull the slide back ONCE after inserting the slide, I say you should also try heavier BBs
Current Guns-
KWA/KSC KP8 .45 (shooter's design slide and outter barrel)
TM MP7 (tightbore barrel)
ICS M4 Pistol (longer rails, slightly longer barrel)
TM Hi Capa 5.1

#3 c4v3man

c4v3man

Posted 13 April 2008 - 11:28 PM

QUOTE (Seven @ Apr 13 2008, 07:55 PM) <{POST_SNAPBACK}>
make sure you only pull the slide back ONCE after inserting the slide, I say you should also try heavier BBs

Yes, I actually only insert the magazine with the slide locked open, then release the slide and begin firing. I was told by the shop where I purchased it the first time that the metal air nozzle may bend if a loaded magazine is inserted while the slide is closed. Sounded bogus, but I'm not taking any chances.

#4 FluffRat

FluffRat

Posted 07 May 2008 - 07:49 PM

Non-poster, found this thread via Google.

I was having the exact same issue and eventually, after much troubleshooting (no pun intended), managed to figure out what was causing it.

The KWA KP45 / KP8 hates puppies, sunshine, joy, rainbows, and Excel .2g biodegradable BBs.

As the gas nozzle retracts over the magazine the top round is pushed forwards ever so slightly. When the BB gets pushed out of alignment with the stack the spring pressure causes it to jump forwards out of the magazine. Where the BB goes when it pops determines if you get a double fire/rollout, a double feed jam, or an ejecting BB. I suspect that the Excel BBs are either slightly slicker or softer than your average rounds, which is why it only happens when using them. I switched from the Excel to whatever that little ziplock is that comes in the box and have so far have fired 5 mags (read: the contents of that baggie) without a single issue.

Can anybody report if regular Excel non-bio BBs have this issue?

#5 TomServo92

TomServo92
  • Location:Texas

Posted 07 May 2008 - 08:21 PM

QUOTE (c4v3man @ Apr 13 2008, 09:34 PM) <{POST_SNAPBACK}>
I purchased a KWA KP8 USP full size pistol back in december, shot about 1000 rounds through it without many problems (maybe like 5 jams/misfeeds). Then I started having CONSTANT problems. I took it back, and after them working on it for a few months, I returned it and purchased one from another supplier. I started having double feeds and jams right off the bat. I am using propane and green gas alternating, and Excel and Airsoft Elite .20 pellets (new, not re-using). Prior to me sending my pistol back to the supplier, I wanted to know if there is anything I can try. I saw a post here that describes part of my problem, and I tried adjusting the hop up on my first pistol before without success. I will try it again tonight, however I doubt I will have much more luck.

Normally I would simply try a different model or brand, however I need my pistol to be a HK USP pistol, since my IWB holster is made for my USP expert, which I concealed carry. I purchased this airsoft simply to allow for me to practice shooting and drawing (potentially for IPSC) cheaper than reloaded .45's. If there is another brand of USP that is known to be more reliable, I would be willing to try that, however it seems unlikely that a manufacturer as good as KWA (from what I hear) would make a known defective product. I clean my pistol regularly, and am using some Gold Cup lubricant on the rails and barrel assembly. I'm going to try putting a spot of oil on the hopup, and perhaps some at the top of the feed lips. Is there anything else I can do?

Problems:
1. Double feed (something it will fire nothing the shot before, sometimes it will shoot 1 then shoot 2)
2. BB will feed in between the hopup/barrel and magazine, causing jam
3. BB will "eject" out of the ejection port while another bb loads fine


Thank you for your help.


I had the same problem with mine. Adjusting the hop up worked for me. I'm not sure what else to tell you do.


-------- TM Sig 552 -------- KWA G19 -------- KWA USP --------

"Happiness is a warm gun"
- Lennon/McCartney

#6 Inu One

Inu One
  • Location:CA

Posted 08 May 2008 - 08:22 AM

Call KWA USA or post on their product support forum.
Primary =>TM G36C, CA M15A2, Systema M4A1-MAX, KWA KM4A1
Side Arm => KWA KP45, KWA M9 PTP




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users