Jump to content



to add your 300x250 banner, pay ad zone 5
Airsoft Atlanta is your source for quality airsoft guns and rifle parts
to add your Text Link here, pay ad zone 3

AirsoftAtlanta.com AirsoftNMore.com Airsplat.com AirsoftRC.com
Vote for us to add your 180x30 banner here, pay ad zone 2

If you appreciate this website, please ASF Donation or Check Out the ASF Store. If you can not help us financially,
then at least help us by telling a friend: Share us on your favorite social networking website Bookmark and Share

Important Announcement!

Our Pinzgauer Project is in "Pre Launch" - Click Here to let us know what you think before the project goes live.

Photo
- - - - -

Help! AGM Sten mk 2 - battery gets piping hot, won't shoot

AGM Sten Mk 2 Hot Battery Wont fire

  • Please log in to reply
3 replies to this topic

#1 mp40guy

mp40guy

Posted 29 October 2017 - 04:20 PM

Dear Forum,

I bought a new Sten Mk 2  AGM airsoft gun. I charged the battery with the supplied charger. Hooked up the battery and the gun won't fire. And the battery gets piping hot in side the storage area in the stock.

I had the company ship me another one and the same situation with the new gun and new battery.  I sent back the first gun and kept the second one.

 

I have partially disassembled the gun to see if I could see something obvious and I didn't notice anything.

Any ideas on what could be causing this?

It seems to be a problem with both guns.

**What should I replace? The battery? Some other electronic component like the motor?

I would like to make this gun work.

Any ideas on what I can do to fix it?

 

Thanks for your advice.

IMG_0124.JPG


Edited by mp40guy, 29 October 2017 - 05:41 PM.

  • 0

#2 Guges Mk3

Guges Mk3
  • Gender:Male
  • Location:Minnesota

  • My Temperament:Sanguine

Posted 30 October 2017 - 06:45 AM

Please provide additional details.  This will help us help you.

 

Battery Type, Make, mah, nominal voltage rating,

Connector type for battery.

 

Do you have any tools for electrical troubleshooting?  Volt Meter, etc...


Edited by Guges Mk3, 30 October 2017 - 10:47 AM.

  • 0
I rather use a "nightmare" that shoots like a dream over something that looks like a "dream" but shoots like a nightmare.

Don't fear the gun...fear the one that's wielding it!

#3 mp40guy

mp40guy

Posted 30 October 2017 - 10:28 AM

The battery is an AGM brand Nickel Metal Hydride Battery. It is 1100mAH and it has seven cells.  Each cell says 1.2 v  2/3A

 Yes, I have a multi meter. 

I set it at the setting on the dial that looks like this:

~

-

v

 

And it says 8.87v

The battery has been sitting for about six months though.  If it would help, I could put it on the charger for a few hours.

I appreciate your help.

What is the next step?

Thanks,

Jeff

 

plug.JPG


  • 0

#4 Guges Mk3

Guges Mk3
  • Gender:Male
  • Location:Minnesota

  • My Temperament:Sanguine

Posted 30 October 2017 - 10:51 AM

The plug.JPG is incomplete.

 

8.87V shows that all cells should be okay.  Fully charged this battery pack should be ~9.8V

 

Please conduct a continuity test on your AEG.  What type of charger is it?  Is it just a transformer or can you set output?

 

Remove motor and connect the leads.  From the battery plug initiate a continuity test.  If it beeps...you have bad wiring and will most likely be indicative of the batch.  AGM is not know for their good QC on their products.


  • 0
I rather use a "nightmare" that shoots like a dream over something that looks like a "dream" but shoots like a nightmare.

Don't fear the gun...fear the one that's wielding it!





Also tagged with one or more of these keywords: AGM Sten Mk 2, Hot Battery, Wont fire

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users