Jump to content

Mordeton

Member
  • Content Count

    14
  • Joined

  • Last visited

  • Feedback

    %

Community Reputation

0 Neutral

About Mordeton

  • Rank
    ASF Immigrant
  • Birthday 02/16/1998

Profile Information

  • Gender
    Male
  • Location
    Oslo, Norway
  1. Product in mind: http://www.evike.com/products/45329/ Hi, anyone have any idea how to fix this problem? WIth my new mag: https://www.youtube.com/watch?v=W248PJPaUqA With old included mag: https://www.youtube.com/watch?v=a8cOO2L0lak I was shooting in a safe direction, no one could see me either. I made sure before I did the test. (Had to get a new mag because this one didnt feed at all) What I have tried: -New mag -lubed up some parts -I filled the mags properly
  2. Thank you to all of the people who helped me fix this problem. After disassembling and assembling the hammer mechanism and changing my method of loading the gas the gun now fires over 1 mag straight! :) Thanks again.
  3. I am not very familiar with how to disassemble this gun and I don't know what to look for. But I will give it a try.
  4. I would guess the nozzle spring. Would polishing the slide make it better? So there is less resistance.
  5. This is the rod right? If so, nothing happened after I cleaned it.
  6. I only have white lithium grease spray. Will that do the job?
  7. Room temperature is 22C. I am using "ULTRAIR POWER GAS" from "ASG" and contains C4H10, C3H8 and has a 99,7% purity. I fill it up from the bottom of the mag. I hold the gas can in the mag for about 3-5 seconds before releasing. I have noticed that the kick from the gun becomes weaker and weaker for every shot. Using a new gas can got me 2-3 more rounds before it wont fire.
  8. I will provide more info asap. Just need to go to school first.
  9. Hello, I am a 16 year old airsofter from Norway. Today I received my M22 GBB Pistol. It worked fine for 4-5 test mags. I sprayed some silicon lube on the slide and other parts, shot 1-2 mags and then this started happening. Things I have done/tried: -Clean the silicone off -New gas canister -Firing without ammo -Checked mag for gas leak Things I have noticed: -The slide meets some resistance halfway up -Sometimes the slide wont go in the fully forwards position (I have to push it the rest of the way) VIDEO: I AM NOT FIRING WITH ANY AMMO. ITS A DRY FIRE TEST. https://www.youtube.com/watch?v=a8cOO2L0lak Thank you for reading :)
×
×
  • Create New...