Jump to content
Sign in to follow this  
sijas

P90 High Cap magazine not winding

Recommended Posts

I have a CA P90 with a 300 round high cap mag and its not working. I have lubed it and tried to "break it in" but its still not winding. When I spin the winding thing, it doesn't make any sounds at all, which isnt right because on youtube all their magazines make clicking noises when they wind it. Any1 know how I can fix this?

Share this post


Link to post
Share on other sites
Guest alberty

You might need to disassemble the magazine and check for any misaligned or broken parts then

Share this post


Link to post
Share on other sites

You mentioned that you lubed it. Does that mean that you opened up and disassembled the magazine, or did you just spray some lubricant in from whatever openings?

 

The clicking sound is generally from that spring that you see to the lower left of the main winding wheel. When spinning the winding wheel, do you see all the gears inside moving (when there are no BBs in there)?

TMP90hicapinside.jpg

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...