Jump to content
Sign in to follow this  
assasain47@aol.com

My KJW Xcelerator refuses to fire!

Recommended Posts

This is really irritating me because I seriously have no idea what is wrong. I bought this gun http://www.airsoftgi.com/product_info.p ... ts_id=5905 and got another we-tec mag with it. It was working great for alittle bit but then suddenly in the middle of a CQB game it stopped firing. I figured eh just a bad mag as the KJW mag worked fine.

 

So after alittle more use the KJW mag I got with it totally stopped working to. So then I figure man both mags cant be bad that doesnt seem plausible. So I did a field strip and cleaned, lubed, and put everything back together. Nothing still. If I'm lucky I can get one bb to kinda of spit out without even the slide moving an inch. On an even better day I can get it to totally cycle and fire ONCE, but nothing after that.

 

I ordered a new fill port and valve to replace on the WEtec mag just to see if maybe it was indeed the magazine causing issue. Replaced them both and tried it, still nothing. Heres the odd thing...on a hunch I took the slide off, slide the mag in, and fired. I was met with all the gas expelling out of the magazine. So after that I have no earthly clue whats going on, as when I put the slide BACK ON, I get nothing at all. No gas escaping, no cycle, nothing except the trigger engaging and the hammer hitting. I do use a propane adapter that I put oil in on the side so I make sure my guns are properly lubed. I have another friend that enjoyed my 1911 so much he bought the same exact one...and now has the same exact problem.Any help on this would be greatly appreciated!

Share this post


Link to post
Share on other sites
I do use a propane adapter that I put oil in on the side so I make sure my guns are properly lubed.

 

The above process is not proper lubing of the gun. It is an improper method that has been propagated by the Internet and people who do not know what they are doing.

 

Need a picture of your lower with the slide off. I have a feeling the the sear maybe worn. Please take a few pictures of the trigger group and sear in the lower grip.

Share this post


Link to post
Share on other sites

Copy that! Thanks for the fast reply! Give me a minute to get the gun back apart. Unfortunetly I left my tools at my great grandparents house so this may take a moment.

Share this post


Link to post
Share on other sites

I just decided to take the entire thing apart to look for wear and tear that could possibly be leading to this malfunction. Ive taken enough pictures I think. The Sear looks fine really (that I can tell, im not an expert though obviously :P). http://s1287.beta.photobucket.com/user/jus...hitman/library/ . If more is needed let me know. There are some parts of the metal that seemed to be worn down from what looks like grinding. Im not sure if that would cause this issue but its there.

Share this post


Link to post
Share on other sites
Guest alberty

If the problem is with your gun, I would guess it could be one of a few parts.

 

- The sear/leaf spring could have been misaligned at some point

- The valve knocker or its spring could have been worn down or misaligned.

- The hammer/sear disconnector could have been worn down.

 

If not that, I would guess the magazines' knocker valves.

Share this post


Link to post
Share on other sites

My buddy had a similar problem. He was using WD40 to lube his gun, we lubed it with silicon and it worked after that. Make sure you dilute your propane with silicon. you'll ruin your magazines and your gun otherwise.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...