Jump to content
Sign in to follow this  
Chewbacca

WE Tech M14 DMR

Recommended Posts

It would really only fluctuate around 20-30 fps if you don't go full auto. Also inherent accuracy in a gas gun on semi would be better than an AEG because in a gas gun, the BB would have already left the barrel before the bolt would start cycling, but in an AEG, the BB would still be in the barrel when the piston head had already slammed at the end of the cylinder moving the gun off the POA.

Share this post


Link to post
Share on other sites

It can be a viable DMR platform, as long as you spend the money to make it so. The only real issue is the fluctuation of fps from the first shot in the mag, to the 20th (don't both with trying to get 30 out of those mags). When the fps drops throughout the mag, the hop up applied to each bb will change; effectively reducing your hop up as you go through the mag.

 

Also, don't even bother considering the gun if you aren't planning on getting the RA-Tech full trigger group. This is especially important for the trigger housing as without the one-piece steel version that RA-Tech makes the gun might last 500 rounds. Aside from the trigger group, you could probably skip the majority of the other upgrades if all you want is the gun to shoot, but be prepared to buy upgrade parts in the future when other parts start breaking.

 

This is all coming from experience, check out the link in my sig if you'd like to see the WE M14 I built.

Share this post


Link to post
Share on other sites

Well, maybe I can get an answer here as opposed to starting a new thread (not wanting to hijack, sorry). I have had the RA tech trigger mech in my we m14 (yes, got the Ebr stock, but you're talking to a guy who goes to weekend events as the support gunner, so yeah...) and I've recently been trying to figure out why it's now only firing in full auto, however when I swap the OEM trigger unit into it, both semi and full auto settings work fine. Anyone else have this issue, and what did you do/heard could correct the problem?

Worst case, I may have to figure out how to just disable full auto, but I'd rather not go that route (esp as it's fun to just crank out a full mag once in a blue moon in the backyard, just for the fun of it).

Edited by Steeljaw36

Share this post


Link to post
Share on other sites

If the semi auto disconnector slips what you get is full auto. If you then disable full auto then the gun won't even fire. I've never really had faith in RATech's CNCed parts as you often need to modify them to function. Check the angle of engagement between the semi auto disconnector and the hammer. Doubt it's worn so it could be a spring that's broken or the angle was off to begin with. Worst case is you need to file the hammer and/or disconnector to correct the angle.

Edited by renegadecow

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...