Jump to content
Sign in to follow this  
emilk93

Urgent! Brand new KWA RM4 not shooting and I need it tomorrow..

Recommended Posts

So I received my RM4 last night, shot it a few times since it was really late and worked fine. This morning I went to actually fire it outside and it wouldn't shoot! I press the trigger, it depressed but nothing happens. I tried to wiggle the little bolt switch inside the mag well that this video shows to do to fix (apparently a lot of people were having a non firing problem with this gun).

 

It doesn't do anything. I got it shooting a few times, and both times it was when I took the hand guard off and touched the wiring. As soon as I put the hand guard back on it would stop shooting once again. This is very irritating and I need this gun for tomorrows game. the fuse seems to be fine as well as the wiring (from what I can tell). What could be causing this problem?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...