Jump to content

to add your 300x250 banner, pay ad zone 5
Airsoft Atlanta is your source for quality airsoft guns and rifle parts
to add your Text Link here, pay ad zone 3

AirsoftAtlanta.com AirsoftNMore.com Airsplat.com AirsoftRC.com
Vote for us to add your 180x30 banner here, pay ad zone 2

If you appreciate this website, please ASF Donation or Check Out the ASF Store. If you can not help us financially,
then at least help us by telling a friend: Share us on your favorite social networking website Bookmark and Share

Recommended Posts

OK, I've seen a thread about this problem already, but I decided that due to the nature of the problem that it was worth doing another thread.

 

Now, onto the meat of this thread: Recently, I've been having trouble getting my G&P M16A1 and CYMA AIMS (CM.050) to feed. Both of them will fire correctly for a few shots and then nothing. When I fired the guns upside down, they feed properly, however. For the M16, I'm using G&P 360-round hi-caps, and for the AIMS, Matrix 600-round hi-caps. I don't want to say that the mags are the problem, but on the other hand, the M16 fired correctly with the stock mid-cap mag.

 

Any thoughts on the matter?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...