Jump to content

Recommended Posts

Hello!

 

I own a generation 3 Elite Force 4CRS.

 

I have had the gun for about 4 months, and it preforms very well. I have upgraded the hopup bucking to a maple leaf 75 degree bucking, and it shoots like a dream. Recently though, the gun has been functioning oddly. The gun still shoots fine, but the gear box is now very loud and does not sound very good at all. It is not the motor height, I have it adjusted correctly. Anyone know if this is something to be concerned about or if the gun is fine?

Share this post


Link to post
Share on other sites
Guest alberty

What do you mean by loud? Has the noise gotten whiny or screechy? Or are you hearing a louder impact from the piston? etc.

Share this post


Link to post
Share on other sites

You really cannot ask that question and get an accurate answer.

 

That is like asking a mechanic about a car (over the internet) that makes a funny noise in the wheel bearings when above 50MPH, if it's okay to drive it 200 miles.

 

You will have to take your chances.

 

This is a good time to get a secondary back-up too.

Share this post


Link to post
Share on other sites
Guest alberty

Without knowing what the actual problem is, it's impossible for us to guess whether or not your gun is fine to use for a while or if it will fail within a few minutes.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...