Jump to content
Togator

Mosfet heating up very fastly (pico SSR 3)

Recommended Posts

I have done some rewireing and I got my mosfet to shortcut. After that I fixed that (took out extra tina that was causing shortcut). Now when I plug battery in, my mosfet starts instantly heating up and causes smoke in 2sec. So is the problem in something else than mosfet or is the reason for problem in the mosfet.

Share this post


Link to post
Share on other sites

Not sure what tina is? And do you mean short (as in electrical short) rather than shortcut?

 

If you plug your battery in and the MOSFET immediately gets hot without pulling the trigger, then you either still have a short or your MOSFET is broke and needs to be replaced.

Share this post


Link to post
Share on other sites

Not sure what tina is? And do you mean short (as in electrical short) rather than shortcut?

 

If you plug your battery in and the MOSFET immediately gets hot without pulling the trigger, then you either still have a short or your MOSFET is broke and needs to be replaced.

Sorry I meant tin but I mistyped and yeah shortcut was wrong term, I ment short (I have bad england) Im also new and still learing to use this website. Thanks lot.

Edited by Togator

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...