Jump to content
Sign in to follow this  
PantherWarrior113

Help! Gun or Battery?

Recommended Posts

Brand new LiPo battery arrived today and I immediately threw it on the smart charger it came with. It didn't take long to charge fully and then it went on my brand new ICS PAR Mk3. It was shooting perfectly in semi but once switched to full auto, 1 round would fire and then nothing. I tried switching back to semi and still nothing. I unplugged the battery from the gun and then placed it back on the charger. It took 3 minutes before it was back to full again. I reconnected the battery to the gun and went straight to full auto. Again, 1 shot and then the gun went dead.  I only have one battery to test it with. I tried putting the battery back on the charger and then back onto the gun with a full charge and nothing is working now. Both semi and full auto are nonresponsive. What is going on? Is it a safety measure built into the battery? For reference, I bought the Matrix High Performance 7.4V Stick Type Airsoft LiPo Battery (Configuration: 1000mAh / 15C / Small Tamiya / BMS Smart Charger Starter Package). I'm rather new to AEG's and could use some help. Thanks!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...