Jump to content
Sign in to follow this  
Pati

AK feeding problem

Recommended Posts

Hi,

I've got a problem I can't seem to fix. The AK won't feed at all.

Long story short: the AK si a LCT AK-74, it did not have feeding problems, at all. Not one. I used it with CYMA high cap mags. Worked fine.

Then I put in a CYMA low cap mag, it got stuck. I mean really stuck. I had to unscrew the trigger guard.

Now it won't feed at all. Not even with LCT high cap mags. 

If I pull on the mag it feeds. But then it stops feeding when I let  go. The trigger guard does not press on the back of the magazine so it will not stay up and feed bbs. 

I bought a CYMA trigger guard, it still doesn't work.

Now I bought a CYMA hop up chamber, the metal one, which solved my feeding problems on a DBOYS AK. I hope it will solve it here also...

I have no idea why it worked perfectly fine before  and now it just doesn't want to feed bbs from the magazines...

 

Any thoughts or ideas? If the new hop up chamber does not solve it I have no idea what to do.

Share this post


Link to post
Share on other sites

You probably changed how the trigger guard seated so it doesnt hold the mags in right. You only messed with one part so most likely that's all that's wrong with it. Unless you broke the hop up unit from jamming the magazine in. Definitely fixable, just gotta figure out what the heck got knocked out of alignment.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...